EMF Forms Migration – please upgrade to 1.5.1

EMF Forms Migration – please upgrade to 1.5.1

In short:

If you are upgrading from 1.4.x or lower to 1.5.x, and you have existing view models, please use the 1.5.1 service release provided on our download page. Luna SR2 contains only 1.5.0. Please also follow our migration guide.

Longer story:

We have recently released EMF Forms 1.5.0. In this release, the view model has been updated. More precisely, the format in which tables are defined has been changed. Therefore, existing view models (the *.viewmodel files) must be migrated to the new format. To make this as simple as possible for our users and adopters, we have used Edapt to provide an automatic migration (see here for technical details). The automatic migration is available on the 1.5.0 update site and was mentioned in the migration guide. Unfortunately, the automatic migration was not included in the 1.5.0 SDK. Primarily, this was because Edapt was not yet part of the release train.

Therefore, if you simply update your SDK feature to 1.5.0, the automatic migration has not been installed. As a result, tables are not loaded in the view model editor during runtime, although, no data is lost. To fix this issue, the easiest solution is to upgrade to 1.5.1, which is available on our download site. Please follow our migration guide to upgrade your existing view models.

We are sorry for any inconvenience, please report any kind of issues.

For our next release, which will be part of Mars, we will add the automatic migration to the SDK.